Zeebe Testing Error

I’ve been following along with the documentation here:

https://docs.zeebe.io/clients/java-client/testing.html

When I fire off the newDeployCommand, this error is continuously thrown:

java.lang.NoSuchMethodError: “long io.netty.channel.epoll.EpollEventLoop.nextScheduledTaskDeadlineNanos()”

The test does not progress past the .join() call, it seems to get stuck in a loop trying to deploy the workflow.

I’m thinking there is some dependency I must be missing, but here is what I have so far:

zeebe-client-java 0.22.2
spring-zeebe-starter 0.22.0
zeebe-test 0.22.2

Hi @rudyj03,

thank you for reporting. It seems like a conflict with a Netty dependency.

Can you try the latest version 0.23.x?

Best regards,
Philipp

1 Like

New dependencies:
zeebe-client-java 0.23.3
spring-zeebe-starter 0.23.0
zeebe-test 0.23.3

Result:
NoClassDefFound org/slf4j/event/Level
at io.zeebe.util.ZbLogger.warn (line 474)
at io.zeebe.test.util.socket.SocketUtil.getTestForkNumber (line 61)
at io.zeebe.test.util.socket.SocketUtil. (line 28)
at io.zeebe.test.EmbeddedBrokerRule.assignSockerAddresses (line 117)
at io.zeebe.test.EmbeddedBrokerRule.configureBroker (line 220)
at io.zeebe.test.EmbeddedBrokerRule.(line 96)
at io.zeebe.test.EmbeddedBrokerRule. (line 69)
at io.zeebe.test.ZeebeTestRule. (line 36)
at io.zeebe.test.ZeebeTestRule. (line 31)

I then explicitly added a dependency for logback-classic but still had the same result.

I’m not sure what changed between 0.22 and 0.23 but I was not seeing the slf4j error previously.

After doing some more digging I realized an unrelated dependency was also pulling in a different slf4j version. I excluded that one and now things are happier.

I’m still not sure what the issue was with the 0.22 zeebe dependencies, but 0.23.3 seems to be working well as far as the testing is concerned.

1 Like

Thank you for the update :+1: