Zeebe-Tasklist not polling user type jobs?

Hi,

I’m trying to setup zeebe-tasklist application under Kubernetes.

Zeebe cluster + Operate installed.
Zeebe version: 0.26.0-alpha2
Elasticsearch version: 6.8.5
TaskList version: 0.26.0-alpha2
Operate version: 0.26.0-alpha2

Tasklist application setup done accordingly to resources:

Configuration - Zeebe Documentation

zeebe-tasklist-helm/configmap.yaml at master · zeebe-io/zeebe-tasklist-helm · GitHub

GitHub - zeebe-io/zeebe-simple-tasklist: Zeebe worker to manage manual/user tasks

Tasklist application is up and running with auth profile. No errors under console. Web UI also working with demo user.

Under Operate task with type (user) exists and waiting for executor, input parameter “assignee”: “demo”. Tasklist still is empty.

Example of my config:

kind: ConfigMap

metadata:

name: zeebe-tasklist-conf

apiVersion: v1

data:

application.yml: |

# Tasklist configuration file

zeebe.tasklist:

# Set Tasklist username and password.

# If user with <username> does not exists it will be created.

# Default: demo/demo

#username:

#password:

# ELS instance to store Tasklist data

elasticsearch:

# Cluster name

clusterName: elasticsearch

url: http://elasticsearch-master:9200

# Host

host: elasticsearch-master

# Transport port

port: 9200

# Zeebe instance

zeebe:

# Broker contact point

brokerContactPoint: zeebe-cluster-zeebe-gateway:26500

# ELS instance to export Zeebe data to

zeebeElasticsearch:

# Cluster name

clusterName: elasticsearch

url: http://elasticsearch-master:9200

# Host

host: elasticsearch-master

# Transport port

port: 9200

# Index prefix, configured in Zeebe Elasticsearch exporter

prefix: zeebe-record

#Spring Boot Actuator endpoints to be exposed

management.endpoints.web.exposure.include: health,info,conditions,configprops,prometheus

# Enable or disable metrics

#management.metrics.export.prometheus.enabled: false

Is it needed to be configured? Or for camunda/zeebe-simple-tasklist:latest I can skip this?

ensure that a Zeebe broker is running with a Hazelcast exporter (>= 0.8.0-alpha1)

forward the Hazelcast port to the docker container (default: 5701)

configure the connection to the Zeebe broker by setting zeebe.client.broker.contactPoint (default: localhost:26500)

configure the connection to Hazelcast by setting zeebe.client.worker.hazelcast.connection (default: localhost:5701)

Hi @Andrej,

please note that there is a difference between zeebe-tasklist and zeebe-simple-tasklist.

Zeebe-Tasklist is an official application by Camunda. It is offered in the Camunda Cloud (as beta).

Zeebe-Simple-Tasklist is a community extension that was implemented before.

For the Zeebe-Tasklist, the job type must be set “humanTask”.
For the Zeebe-Simple-Tasklist, the job type must be set to “user”.

In the Helm chart, it set up the Zeebe-Tasklist.

Does this help you?

Best regards,
Philipp

1 Like

Hi Philipp,

Yes, it’s working.

Is it legal to use with Zeebe Cluster installation instead of Camunda Cloud? Same as Camunda Operate?

Thank you.

Regards,
Andrej

I guess that it has the same license as Operate. Trial version under a developer license for free, non-production use only.
See more here: https://zeebe.io/zeebe-license-overview/

@jwulf is this correct?