Zeebe standalone gateway

Hi,

I am trying to configure a standalone gateway in my local machine before migrating to kubernetes .
Version : 0.23.2
Broker Config

Gateway Config

But getting following warning from gateway console

looks like the Gateway also trying to use the cluster bind port 26502.

please can you help me this ?

Thanks,
Eapen T John

Hi @eapenjohn,

I’m sorry to see that no-one has answered your post yet. I’ve tried to reproduce your situation locally, but I’ve not been able to achieve that. Given the config details above, the broker and gateway can individually start-up successfully for me.

Please share your full broker and gateway configurations (for example as a Github gist), so I can try to reproduce the problem.

Best,

Nico

Hi Nico,
thank you for your response .i couldn’t make much progress on this
broker config: and Gateway config

Now i am getting following exception from gateway when try to connect using localhost:26800

Thanks,
Eapen T John

Hi @eapenjohn,

I’ve been able to find the misconfiguration. There is no config property zeebe.broker.network.port in the broker configuration. I think it is currently not possible to directly change the port of the broker.

In fact, the broker uses multiple ports starting at 26500. According to the configuration template documentation you can make changes to it using a portOffset:

# If a port offset is set it will be added to all ports specified in the config
# or the default values. This is a shortcut to not always specifying every port.
#
# The offset will be added to the second last position of the port, as Zeebe
# requires multiple ports. As example a portOffset of 5 will increment all ports
# by 50, i.e. 26500 will become 26550 and so on.
#
# This setting can also be overridden using the environment variable ZEEBE_BROKER_NETWORK_PORTOFFSET.
# portOffset: 0

I recommend you remove that property from the broker config AND alter the gateway config with the following properties:

zeebe:
  gateway:
    cluster:
      # this is the port that the broker is reachable at with portOffset=0
      contactPoint: 0.0.0.0:26502

      # should be different from zeebe.gateway.network.port 
      # as it is used for other communication
      port: 26900

    network:
      # we can leave this one the same
      port: 26800

I hope this helps. Please let me know if you have any further questions.

1 Like

Hi Nico,

thank you for your help . it is working in my local machine with separate broker and gateway instance.

we are planning to deploy this in Kubernetes with cluster size of three and two gateways as per the documentation . but somewhere in the GitHub saw, gateway always need a single broker for the initial contact point . Please can you validate my understanding ?

Thanks,
Eapen T John

Hi @eapenjohn,

As far as I know our gateway configuration can only deal with one initial contact point. However, because you’re deploying to k8s I think you could try something like discussed here:

Perhaps @salaboy, can help with this, as I’m not yet familiar enough with this.

thanks Nico. i am able to configure the gateway using cluster loadbalancer url