Updating Index replica count created by Operate

Hi
I recently deployed Operate to our development k8s cluster and found that ElasticSearch pod wouldn’t start. After a little investigation I found that Operate creates several ES indexes each with a number_of_replicas count of 1.

I should state that our development environment is very small:

zeebe-cluster:
  clusterSize: 1
  partitionCount: 1
  replicationFactor: 1
  ...
  elasticsearch:
    replicas: 1
    minimumMasterNodes: 1
    ...

To fix this issue I manually updated each index e.g. using port-forward I was able to use Postman to update each index

PUT: http://localhost:9200/operate-user-1.2.0_/_settings?pretty

{
    "index" : {
        "number_of_replicas" : 0
    }
}

I was wondering is there and easier way to configure Operate to create indexes with no replicas i.e. providing addition values when deploying the operate helm chart?

Thanks
Andy

@andyh this is ok for now, the team mentioned me that they are working on some other mechanisms for version 0.23.0 of Operate (with the new version strategy), so that might change in the future.

Hi Andy,
if I’m not mistaken, Operate 1.2.0 does not define any number of shards and number of replicas, meaning that Elasticsearch defaults will be applied. There are several ways to approach the problem then:

  1. configure another default values for elasticsearch (I believe you can change it in elasticsearch.yml)
  2. before running Operate, create template like this:
    PUT _template/template_operate
    {
    “index_patterns”: [“operate-*”],
    “settings”: {
    “number_of_shards”: 3,
    “number_of_replicas”: 0
    }
    }
  3. Your way must also work

Best regards,
Svetlana