Running instance not showing on Camunda operate

Hi I have just started with Zeebe and I am following the getting started tutorial.

So I have managed to deploy the workflow but I do not see the running instance in Camunda operate as it has stated in the workflow. What can i check?

[https://docs.zeebe.io/getting-started/deploy-a-workflow.html](http://Deploy a workflow)

1 Like

Deploying a workflow (definition) does not create a running workflow. Creating a workflow instance does.

1 Like

Same for me, I’m able to access operate pointing to my zeebe gateway
Start process works fine but no data is available

Below my docker-compose file:

version: β€œ2”
networks:
zeebe_network:
driver: bridge
volumes:
zeebe_data:
zeebe_elasticsearch_data:
services:
gateway:
restart: always
container_name: gateway
image: camunda/zeebe:0.23.1
environment:
- ZEEBE_LOG_LEVEL=debug
- ZEEBE_STANDALONE_GATEWAY=true
- ZEEBE_GATEWAY_NETWORK_HOST=0.0.0.0
- ZEEBE_GATEWAY_NETWORK_PORT=26500
- ZEEBE_GATEWAY_CLUSTER_CONTACTPOINT=node0:26502
- ZEEBE_GATEWAY_CLUSTER_PORT=26502
- ZEEBE_GATEWAY_CLUSTER_HOST=gateway
ports:
- β€œ26500:26500”
- β€œ9600:9600”
- β€œ5701:5701”
volumes:
- zeebe_data:/usr/local/zeebe/data
- …/lib/zeebe-hazelcast-exporter.jar:/usr/local/zeebe/exporters/zeebe-hazelcast-exporter.jar
- ./application.yaml:/usr/local/zeebe/config/application.yaml
networks:
- zeebe_network
node0:
container_name: zeebe_broker_1
image: camunda/zeebe:0.23.1
environment:
- ZEEBE_LOG_LEVEL=debug
- ZEEBE_NODE_ID=0
- ZEEBE_PARTITIONS_COUNT=2
- ZEEBE_REPLICATION_FACTOR=3
- ZEEBE_CLUSTER_SIZE=3
- ZEEBE_CONTACT_POINTS=node0:26502
networks:
- zeebe_network
node1:
container_name: zeebe_broker_2
image: camunda/zeebe:0.23.1
environment:
- ZEEBE_LOG_LEVEL=debug
- ZEEBE_NODE_ID=1
- ZEEBE_PARTITIONS_COUNT=2
- ZEEBE_REPLICATION_FACTOR=3
- ZEEBE_CLUSTER_SIZE=3
- ZEEBE_CONTACT_POINTS=node0:26502
networks:
- zeebe_network
depends_on:
- node0
node2:
container_name: zeebe_broker_3
image: camunda/zeebe:0.23.1
environment:
- ZEEBE_LOG_LEVEL=debug
- ZEEBE_NODE_ID=2
- ZEEBE_PARTITIONS_COUNT=2
- ZEEBE_REPLICATION_FACTOR=3
- ZEEBE_CLUSTER_SIZE=3
- ZEEBE_CONTACT_POINTS=node0:26502
networks:
- zeebe_network
depends_on:
- node1
operate:
container_name: operate
image: camunda/operate:0.23.0
ports:
- β€œ8080:8080”
volumes:
- …/lib/application.yml:/usr/local/operate/config/application.yml
depends_on:
- gateway
- elasticsearch
networks:
- zeebe_network
elasticsearch:
container_name: elasticsearch
image: docker.elastic.co/elasticsearch/elasticsearch-oss:6.7.1
ports:
- β€œ9200:9200”
environment:
- discovery.type=single-node
- cluster.name=elasticsearch
- β€œES_JAVA_OPTS=-Xms512m -Xmx512m”
volumes:
- zeebe_elasticsearch_data:/usr/share/elasticsearch/data
networks:
- zeebe_network
kibana:
container_name: kibana
image: docker.elastic.co/kibana/kibana-oss:6.7.1
ports:
- β€œ5601:5601”
depends_on:
- gateway
- elasticsearch
networks:
- zeebe_network
monitor:
container_name: zeebe_monitor
image: camunda/zeebe-simple-monitor:0.18.0
environment:
- zeebe.client.broker.contactPoint=gateway:26500
- zeebe.worker.hazelcast.connection=gateway:5701
volumes:
- ./simple-monitor-application.yaml:/usr/local/zeebe/config/application.yaml
ports:
- β€œ8082:8082”
depends_on:
- gateway
networks:
- zeebe_network

Simple operate application.yaml

camunda.operate:
elasticsearch:
clusterName: elasticsearch
host: elasticsearch
port: 9200
zeebe:
brokerContactPoint: gateway:26500
zeebeElasticsearch:
clusterName: elasticsearch
host: elasticsearch
port: 9200
prefix: zeebe-record
logging:
level:
ROOT: INFO
org.camunda.operate: DEBUG
management.endpoints.web.exposure.include: health,info,conditions,configprops,prometheus

Probably I’m wrong, please aplogize me for the indentation

I also noticed these operate logs

No index found for alias zeebe-record-job
No index found for alias zeebe-record-deployment
No index found for alias zeebe-record-workflow-instance
No index found for alias zeebe-record-variable
No index found for alias zeebe-record-incident

Hi All,
Solved fixing the docker-compose and nodes application.yaml as below which I hope can be of help

version: "2"
  networks:
    zeebe_network:
      driver: bridge
      
  volumes:
    zeebe_data:
    zeebe_elasticsearch_data:

  services:
    gateway:
      restart: always
      container_name: gateway
      image: camunda/zeebe:0.23.1
      environment:
        - ZEEBE_LOG_LEVEL=debug
        - ZEEBE_STANDALONE_GATEWAY=true
        - ZEEBE_GATEWAY_NETWORK_HOST=0.0.0.0
        - ZEEBE_GATEWAY_NETWORK_PORT=26500
        - ZEEBE_GATEWAY_CLUSTER_CONTACTPOINT=node0:26502
        - ZEEBE_GATEWAY_CLUSTER_PORT=26502
        - ZEEBE_GATEWAY_CLUSTER_HOST=gateway
      ports:
        - "26500:26500"
        - "9600:9600"
        - "5701:5701"
      networks:
        - zeebe_network
    node0:
      container_name: zeebe_broker_1
      image: camunda/zeebe:0.23.1
      environment:
        - ZEEBE_LOG_LEVEL=debug
        - ZEEBE_NODE_ID=0
        - ZEEBE_PARTITIONS_COUNT=2
        - ZEEBE_REPLICATION_FACTOR=3
        - ZEEBE_CLUSTER_SIZE=3
        - ZEEBE_CONTACT_POINTS=node0:26502    
      networks:
        - zeebe_network
      volumes:
        - ./application.yaml:/usr/local/zeebe/config/application.yaml
        - ../lib/zeebe-hazelcast-exporter.jar:/usr/local/zeebe/exporters/zeebe-hazelcast-exporter.jar      
      depends_on:
        - elasticsearch   
    node1:
      container_name: zeebe_broker_2
      image: camunda/zeebe:0.23.1
      environment:
        - ZEEBE_LOG_LEVEL=debug
        - ZEEBE_NODE_ID=1
        - ZEEBE_PARTITIONS_COUNT=2
        - ZEEBE_REPLICATION_FACTOR=3
        - ZEEBE_CLUSTER_SIZE=3
        - ZEEBE_CONTACT_POINTS=node0:26502
      networks:
        - zeebe_network
      volumes:
        - ./application.yaml:/usr/local/zeebe/config/application.yaml
        - ../lib/zeebe-hazelcast-exporter.jar:/usr/local/zeebe/exporters/zeebe-hazelcast-exporter.jar           
      depends_on:
        - elasticsearch
        - node0      
    node2:
      container_name: zeebe_broker_3
      image: camunda/zeebe:0.23.1
      environment:
        - ZEEBE_LOG_LEVEL=debug
        - ZEEBE_NODE_ID=2
        - ZEEBE_PARTITIONS_COUNT=2
        - ZEEBE_REPLICATION_FACTOR=3
        - ZEEBE_CLUSTER_SIZE=3
        - ZEEBE_CONTACT_POINTS=node0:26502
      networks:
        - zeebe_network     
      volumes:
        - ./application.yaml:/usr/local/zeebe/config/application.yaml
        - ../lib/zeebe-hazelcast-exporter.jar:/usr/local/zeebe/exporters/zeebe-hazelcast-exporter.jar      
      depends_on:
        - elasticsearch
        - node1
    operate:
      container_name: operate
      image: camunda/operate:0.23.0
      ports:
        - "8080:8080"
      volumes:
        - ../lib/application.yml:/usr/local/operate/config/application.yml
      depends_on:
        - gateway   
        - elasticsearch
      networks:
        - zeebe_network
    elasticsearch:
      container_name: elasticsearch
      image: docker.elastic.co/elasticsearch/elasticsearch-oss:6.7.1
      ports:
        - "9200:9200"
      environment:
        - discovery.type=single-node
        - cluster.name=elasticsearch
        - "ES_JAVA_OPTS=-Xms512m -Xmx512m"
      volumes:
        - zeebe_elasticsearch_data:/usr/share/elasticsearch/data
      networks:
        - zeebe_network
    kibana:
      container_name: kibana
      image: docker.elastic.co/kibana/kibana-oss:6.7.1
      ports:
        - "5601:5601"
      depends_on:
        - elasticsearch      
      networks:
        - zeebe_network

application.yaml:

zeebe:
  broker:
    gateway:
      enable: true

      network:
        port: 26500

      security:
        enabled: false

    network:
      host: 0.0.0.0

    data:
      directories: [data]
      logSegmentSize: 512MB
      snapshotPeriod: 15m

    cluster:
      clusterSize: 1
      replicationFactor: 1
      partitionsCount: 1

    threads:
      ioThreadCount: 2
    exporters:
      elasticsearch:
        className: io.zeebe.exporter.ElasticsearchExporter

        args:
          url: http://elasticsearch:9200

          bulk:
            delay: 5
            size: 1000

          # authentication:
          #   username: elastic
          #   password: changeme

          index:
            prefix: zeebe-record
            createTemplate: true

            command: false
            event: true
            rejection: false

            deployment: true
            error: true
            incident: true
            job: true
            jobBatch: false
            message: false
            messageSubscription: false
            variable: true
            variableDocument: true
            workflowInstance: true
            workflowInstanceCreation: false
            workflowInstanceSubscription: false

            ignoreVariablesAbove: 32677
      hazelcast:
        className: io.zeebe.hazelcast.exporter.HazelcastExporter
        jarPath: exporters/zeebe-hazelcast-exporter.jar

In this way I’m able to set up:

  • Standalone Gateway
  • Zeebe Cluster
  • Elasticsearch
  • Kibana
  • Operate
1 Like

Good work @user0409!

If this works for you @Bisoux, can you please mark it as the solution.