Problem with Compose up Docker Image

Had it up and running at one point, was getting an error trying to deploy a workflow, tried starting over from scratch and now i’m getting this error when trying to up my docker file.
Can’t tell if it’s an docker error or a zeebe error?

$ docker-compose up
Recreating zeebe_broker … error

ERROR: for zeebe_broker Cannot start service zeebe: error while creating mount source path ‘/host_mnt/c/zeebe/zeebecompose/zeebe-docker-compose/broker-only/zeebe.cfg.toml’: mkdir /host_mnt/c/zeebe: file exists

ERROR: for zeebe Cannot start service zeebe: error while creating mount source path ‘/host_mnt/c/zeebe/zeebecompose/zeebe-docker-compose/broker-only/zeebe.cfg.toml’: mkdir /host_mnt/c/zeebe: file exists
Encountered errors while bringing up the project.

Docker issue. This may help:

I thought it may be a docker issue, i tired everything i found online and nothing worked. So i uninstalled docker and reinstalled it, got the broker-only box up from this tutorial.

the problem is now when i go to check the status with zbctl.exe status.
What’s driving me nuts is i had this up and running the first time i tried but since then i haven’t been able to get through the basic tutorials without error.
I followed the mentioned above tutorial until i received the error below.
I receive an error. (below)
Error: rpc error: code = Unavailable desc = all SubConns are in TransientFailure, latest connection error: connection error: desc = “transport: authentication handshake failed: tls: first record does not look like a TLS handshake”

Thanks for persevering with this @IamManifold.

Use the —insecure flag.

Would you mind PR’ing that into the README of the docker-compose repo? It’s in the release notes for 0.21 on the blog, but we need to make it more discoverable!

I sent you a message, Thank you.

The --insecure flag worked.

After sending you a message and re-reading your post. I think i understand what you were asking but maybe you can confirm in the response to the message i sent you.

Yeah, we should document this in the docker-compose README. You can PR this in if you like, for the GitHub fame.

I also opened this: