Operate can not get partitons

My zeebe cluster contains 3 nodes, and bind to host:myhost, when i start operator, i get many info logs about partions not found.

application.yml
zeebe:
# Broker contact point
brokerContactPoint: myhost:26500

LOG:
2020-09-25 17:44:22.371 INFO 31772 — [ main] o.c.o.z.PartitionHolder : Partition ids can’t be fetched from Zeebe. Try next round (1).
2020-09-25 17:44:22.371 INFO 31772 — [ Thread-514] o.c.o.z.PartitionHolder : Partition ids can’t be fetched from Zeebe. Try next round (1).
2020-09-25 17:44:23.379 INFO 31772 — [ Thread-514] o.c.o.z.PartitionHolder : Partition ids can’t be fetched from Zeebe. Try next round (2).
2020-09-25 17:44:23.379 INFO 31772 — [ main] o.c.o.z.PartitionHolder : Partition ids can’t be fetched from Zeebe. Try next round (2).

problem has been solved!

1 Like

What was it? In case someone else runs into it.

host config of broker(application.yaml) must use real ip, not 0.0.0.0:

commandApi:
# Overrides the host used for gateway-to-broker communication
# This setting can also be overridden using the environment variable ZEEBE_BROKER_NETWORK_COMMANDAPI_HOST.
host: 10.1.1.64

    # Sets the port used for gateway-to-broker communication
    # This setting can also be overridden using the environment variable ZEEBE_BROKER_NETWORK_COMMANDAPI_PORT.
    port: 26501

  internalApi:
    # Overrides the host used for internal broker-to-broker communication
    # This setting can also be overridden using the environment variable ZEEBE_BROKER_NETWORK_INTERNALAPI_HOST.
    host: 10.1.1.64

    # Sets the port used for internal broker-to-broker communication
    # This setting can also be overridden using the environment variable ZEEBE_BROKER_NETWORK_INTERNALAPI_PORT.
    port: 26502

  monitoringApi:
    # Overrides the host used for exposing monitoring information
    # This setting can also be overridden using the environment variable ZEEBE_BROKER_NETWORK_MONITORINGAPI_HOST.
    host: 10.1.1.64

    # Sets the port used for exposing monitoring information
    # This setting can also be overridden using the environment variable ZEEBE_BROKER_NETWORK_MONITORINGAPI_PORT.
    port: 9600
1 Like

Can you mark your comment as the solution please.