Is it possible to disable persistence?

Can one prevent the broker from writing any state or snapshots to disk and work completely in-memory?

1 Like

RAM Disk bro:

It’s all in-memory when your disk is in RAM

2 Likes

I tried that already and it’s not enough. I’d like to avoid any unnecessary copying of data completely because it is not needed for the use case.

1 Like

What about RAM Disk + maxSnapshot=0 ?

Or, if zero is not valid for this parameter: maxSnapshot=1 and snapshotPeriod = "1500000000000000000m"

Of course, that second config is a Y2K-bug-style OOM waiting to happen. Hopefully, long after you have left the building… Or after the PR to disable snapshots is merged.

Update: 0.22-alpha.2 starts with maxSnapshot=0

"data": {
zeebe_broker |     "directories": [
zeebe_broker |       "/usr/local/zeebe/data"
zeebe_broker |     ],
zeebe_broker |     "logSegmentSize": "512M",
zeebe_broker |     "snapshotPeriod": "15m",
zeebe_broker |     "raftSegmentSize": "512M",
zeebe_broker |     "maxSnapshots": 0
zeebe_broker |   },
1 Like